Discussion:
Installation Zope 2.9 sous Ubuntu 10.04 Lucid Lynx
(too old to reply)
Florent JOUATTE
2011-04-07 14:38:26 UTC
Permalink
Raw Message
Bonjour,

J'essaye d'installer une instance CPS sous Ubuntu 10.04 Lucid Lynx en suivant les conseils prodigués ici http://cps-cms.org/sections/download, malgré ça je n'y arrive pas, des erreurs persistent.

Voici la trace de mes commandes :

$ sudo apt-get update

Réception de : 1 http://apt.cps-cms.org lenny Release.gpg [490B]
Atteint http://ppa.launchpad.net lucid Release.gpg
Ign http://ppa.launchpad.net/mozillateam/firefox-stable/ubuntu/ lucid/main Translation-fr
Atteint http://fr.archive.ubuntu.com lucid Release.gpg
Atteint http://fr.archive.ubuntu.com/ubuntu/ lucid/main Translation-fr
Atteint http://fr.archive.ubuntu.com/ubuntu/ lucid/restricted Translation-fr
Atteint http://fr.archive.ubuntu.com/ubuntu/ lucid/universe Translation-fr
Atteint http://fr.archive.ubuntu.com/ubuntu/ lucid/multiverse Translation-fr
Atteint http://fr.archive.ubuntu.com lucid-updates Release.gpg
Ign http://apt.cps-cms.org/debian/ lenny/main Translation-fr
Ign http://apt.cps-cms.org/debian/ lenny/contrib Translation-fr
Atteint http://apt.cps-cms.org lenny Release.gpg
Ign http://apt.cps-cms.org/opt-debian/ lenny/main Translation-fr
Atteint http://security.ubuntu.com lucid-security Release.gpg
Ign http://security.ubuntu.com/ubuntu/ lucid-security/main Translation-fr
Ign http://security.ubuntu.com/ubuntu/ lucid-security/restricted Translation-fr
Ign http://apt.cps-cms.org/opt-debian/ lenny/contrib Translation-fr
Atteint http://ppa.launchpad.net lucid Release
Ign http://fr.archive.ubuntu.com/ubuntu/ lucid-updates/main Translation-fr
Ign http://fr.archive.ubuntu.com/ubuntu/ lucid-updates/restricted Translation-fr
Ign http://fr.archive.ubuntu.com/ubuntu/ lucid-updates/universe Translation-fr
Ign http://fr.archive.ubuntu.com/ubuntu/ lucid-updates/multiverse Translation-fr
Atteint http://fr.archive.ubuntu.com lucid Release
Réception de : 2 http://apt.cps-cms.org lenny Release [4 374B]
Ign http://security.ubuntu.com/ubuntu/ lucid-security/universe Translation-fr
Ign http://security.ubuntu.com/ubuntu/ lucid-security/multiverse Translation-fr
Atteint http://security.ubuntu.com lucid-security Release
Atteint http://ppa.launchpad.net lucid/main Packages
Atteint http://fr.archive.ubuntu.com lucid-updates Release
Atteint http://apt.cps-cms.org lenny Release
Atteint http://security.ubuntu.com lucid-security/main Packages
Atteint http://fr.archive.ubuntu.com lucid/main Packages
Atteint http://fr.archive.ubuntu.com lucid/restricted Packages
Atteint http://fr.archive.ubuntu.com lucid/main Sources
Atteint http://fr.archive.ubuntu.com lucid/restricted Sources
Atteint http://fr.archive.ubuntu.com lucid/universe Packages
Atteint http://security.ubuntu.com lucid-security/restricted Packages
Atteint http://security.ubuntu.com lucid-security/main Sources
Atteint http://security.ubuntu.com lucid-security/restricted Sources
Atteint http://security.ubuntu.com lucid-security/universe Packages
Atteint http://security.ubuntu.com lucid-security/universe Sources
Atteint http://security.ubuntu.com lucid-security/multiverse Packages
Atteint http://fr.archive.ubuntu.com lucid/universe Sources
Atteint http://fr.archive.ubuntu.com lucid/multiverse Packages
Atteint http://fr.archive.ubuntu.com lucid/multiverse Sources
Atteint http://fr.archive.ubuntu.com lucid-updates/main Packages
Atteint http://fr.archive.ubuntu.com lucid-updates/restricted Packages
Atteint http://fr.archive.ubuntu.com lucid-updates/main Sources
Atteint http://fr.archive.ubuntu.com lucid-updates/restricted Sources
Atteint http://fr.archive.ubuntu.com lucid-updates/universe Packages
Atteint http://security.ubuntu.com lucid-security/multiverse Sources
Atteint http://fr.archive.ubuntu.com lucid-updates/universe Sources
Atteint http://fr.archive.ubuntu.com lucid-updates/multiverse Packages
Atteint http://fr.archive.ubuntu.com lucid-updates/multiverse Sources
491o réceptionnés en 0s (644o/s)
W: Impossible de récupérer http://apt.cps-cms.org/debian/dists/lenny/Release Unable to find expected entry main/binary-amd64/Packages in Meta-index file (malformed Release file?)
W: Impossible de récupérer http://apt.cps-cms.org/opt-debian/dists/lenny/Release Unable to find expected entry main/binary-amd64/Packages in Meta-index file (malformed Release file?)
E: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.


$ sudo apt-get install opt-zope2.9

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet opt-zope2.9

En espérant que vous pourrez m'aider, merci d'avance.

Cordialement,

Florent Jouatte
Georges Racinet
2011-04-07 14:44:44 UTC
Permalink
Raw Message
Post by Florent JOUATTE
Bonjour,
J'essaye d'installer une instance CPS sous Ubuntu 10.04 Lucid Lynx en suivant les conseils prodigués ici http://cps-cms.org/sections/download, malgré ça je n'y arrive pas, des erreurs persistent.
A priori, le problème est que vous êtes branché sur les dépôts pour
Lenny, or pour Lucid, il faut se mettre sur celui pour Squeeze.
Et en effet, le paquet opt-zope29 n'existe pas pour Lenny, car Lenny
fournit une installation officielle de Zope 2.9.
C'est dit dans la doc citée, mais peut-être n'est-ce pas assez mis en
avant. Si vous avez des suggestions…
--
Georges Racinet, http://www.racinet.fr
Zope/CPS expertise, assistance & development
GPG: 0x4862FFF7 identi.ca & twitter: gracinet
Georges Racinet
2011-04-07 15:05:19 UTC
Permalink
Raw Message
Post by Georges Racinet
pour Lucid, il faut se mettre sur celui pour Squeeze.
Petite remarque subsidiaire : pour l'instant nous n'avons pas ressenti
le besoin de faire des dépôts à part pour Lucid et Maverick (10.10), car
il semble que les paquets pour Squeeze fonctionnent bien.

Cela dit, cela peut être source de confusion, et ce ne serait pas un
gros effort de mettre les mêmes paquets dans de nouveaux dépôts pour
Lucid et Maverick ; il faudrait quand même que cela vaille le coup en
termes de nombre de personnes intéressées.

Pour finir, nous n'avons pas encore fait d'annonces sur ces listes à
propos de ces paquets pour les distributions ne fournissant pas python
2.4. Ils sont en effet assez récents, mais le temps passe vite…
--
Georges Racinet, http://www.racinet.fr
Zope/CPS expertise, assistance & development
GPG: 0x4862FFF7 identi.ca & twitter: gracinet
Florent JOUATTE
2011-04-07 16:12:14 UTC
Permalink
Raw Message
Tout d'abord merci pour vos réponses.

Quand vous dites que je suis branché sur le mauvais dépôt, qu'est ce que cela signifie concrètement ?

Faut il que je change les lignes suivantes : deb http://apt.cps-cms.org/debian lenny main contrib; deb http://apt.cps-cms.org/opt-debian lenny main contrib en
deb http://apt.cps-cms.org/debian squeeze main contrib; deb http://apt.cps-cms.org/opt-debian squeeze main contrib ?

Désolé, je ne suis pas encore très à l'aise avec Ubuntu (et Linux en général malheureusement).

Merci !

Cordialement,

Florent Jouatte
M.-A. DARCHE
2011-04-07 17:17:10 UTC
Permalink
Raw Message
Post by Florent JOUATTE
Quand vous dites que je suis branché sur le mauvais dépôt, qu'est ce que cela signifie concrètement ?
Faut il que je change les lignes suivantes : deb http://apt.cps-cms.org/debian lenny main contrib; deb http://apt.cps-cms.org/opt-debian lenny main contrib en
deb http://apt.cps-cms.org/debian squeeze main contrib; deb http://apt.cps-cms.org/opt-debian squeeze main contrib ?
C'est ça.

$ man sources.list
--
Marc-Aurèle DARCHE
AFUL http://aful.org/
Association Francophone des Utilisateurs de Logiciels Libres
French speaking Libre Software Users' Association
Florent JOUATTE
2011-04-08 07:57:49 UTC
Permalink
Raw Message
Bonjour,

Je viens d'effectuer plusieurs essais en remplaçant lenny par squeeze, mais ça ne semble pas mieux fonctionner.

Voici les traces :

$ sudo apt-get update

Ign http://apt.cps-cms.org squeeze Release.gpg
Ign http://apt.cps-cms.org/debian/ squeeze/main Translation-fr
Ign http://apt.cps-cms.org/debian/ squeeze/contrib Translation-fr
Atteint http://security.ubuntu.com lucid-security Release.gpg
Ign http://security.ubuntu.com/ubuntu/ lucid-security/main Translation-fr
Ign http://security.ubuntu.com/ubuntu/ lucid-security/restricted Translation-fr
Atteint http://apt.cps-cms.org squeeze Release.gpg
Ign http://apt.cps-cms.org/opt-debian/ squeeze/main Translation-fr
Ign http://apt.cps-cms.org/opt-debian/ squeeze/contrib Translation-fr
Atteint http://ppa.launchpad.net lucid Release.gpg
Ign http://ppa.launchpad.net/mozillateam/firefox-stable/ubuntu/ lucid/main Translation-fr
Ign http://apt.cps-cms.org squeeze Release
Atteint http://fr.archive.ubuntu.com lucid Release.gpg
Atteint http://fr.archive.ubuntu.com/ubuntu/ lucid/main Translation-fr
Atteint http://fr.archive.ubuntu.com/ubuntu/ lucid/restricted Translation-fr
Atteint http://fr.archive.ubuntu.com/ubuntu/ lucid/universe Translation-fr
Atteint http://fr.archive.ubuntu.com/ubuntu/ lucid/multiverse Translation-fr
Atteint http://fr.archive.ubuntu.com lucid-updates Release.gpg
Ign http://security.ubuntu.com/ubuntu/ lucid-security/universe Translation-fr
Ign http://security.ubuntu.com/ubuntu/ lucid-security/multiverse Translation-fr
Atteint http://security.ubuntu.com lucid-security Release
Atteint http://ppa.launchpad.net lucid Release
Atteint http://apt.cps-cms.org squeeze Release
Ign http://fr.archive.ubuntu.com/ubuntu/ lucid-updates/main Translation-fr
Ign http://fr.archive.ubuntu.com/ubuntu/ lucid-updates/restricted Translation-fr
Ign http://fr.archive.ubuntu.com/ubuntu/ lucid-updates/universe Translation-fr
Ign http://fr.archive.ubuntu.com/ubuntu/ lucid-updates/multiverse Translation-fr
Atteint http://fr.archive.ubuntu.com lucid Release
Atteint http://security.ubuntu.com lucid-security/main Packages
Ign http://apt.cps-cms.org squeeze/main Packages
Ign http://apt.cps-cms.org squeeze/contrib Packages
Atteint http://ppa.launchpad.net lucid/main Packages
Atteint http://fr.archive.ubuntu.com lucid-updates Release
Atteint http://security.ubuntu.com lucid-security/restricted Packages
Atteint http://security.ubuntu.com lucid-security/main Sources
Atteint http://security.ubuntu.com lucid-security/restricted Sources
Atteint http://security.ubuntu.com lucid-security/universe Packages
Atteint http://security.ubuntu.com lucid-security/universe Sources
Atteint http://security.ubuntu.com lucid-security/multiverse Packages
Ign http://apt.cps-cms.org squeeze/main Packages
Atteint http://fr.archive.ubuntu.com lucid/main Packages
Atteint http://fr.archive.ubuntu.com lucid/restricted Packages
Atteint http://fr.archive.ubuntu.com lucid/main Sources
Atteint http://fr.archive.ubuntu.com lucid/restricted Sources
Atteint http://fr.archive.ubuntu.com lucid/universe Packages
Atteint http://security.ubuntu.com lucid-security/multiverse Sources
Ign http://apt.cps-cms.org squeeze/contrib Packages
Atteint http://fr.archive.ubuntu.com lucid/universe Sources
Atteint http://fr.archive.ubuntu.com lucid/multiverse Packages
Atteint http://fr.archive.ubuntu.com lucid/multiverse Sources
Atteint http://fr.archive.ubuntu.com lucid-updates/main Packages
Atteint http://fr.archive.ubuntu.com lucid-updates/restricted Packages
Atteint http://fr.archive.ubuntu.com lucid-updates/main Sources
Atteint http://fr.archive.ubuntu.com lucid-updates/restricted Sources
Atteint http://fr.archive.ubuntu.com lucid-updates/universe Packages
Err http://apt.cps-cms.org squeeze/main Packages
404 Not Found
Atteint http://fr.archive.ubuntu.com lucid-updates/universe Sources
Atteint http://fr.archive.ubuntu.com lucid-updates/multiverse Packages
Err http://apt.cps-cms.org squeeze/contrib Packages
404 Not Found
Atteint http://fr.archive.ubuntu.com lucid-updates/multiverse Sources
W: Impossible de récupérer http://apt.cps-cms.org/opt-debian/dists/squeeze/Release Unable to find expected entry main/binary-amd64/Packages in Meta-index file (malformed Release file?)
W: Impossible de récupérer http://apt.cps-cms.org/debian/dists/squeeze/main/binary-amd64/Packages.gz 404 Not Found
W: Impossible de récupérer http://apt.cps-cms.org/debian/dists/squeeze/contrib/binary-amd64/Packages.gz 404 Not Found
E: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.

$ sudo apt-get install opt-zope2.9

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet opt-zope2.9

Je ne comprend pas, y a t-il à votre connaissance des cas similaires ?

Merci.

Cordialement,

Florent Jouatte
Georges Racinet
2011-04-11 09:03:51 UTC
Permalink
Raw Message
Post by Florent JOUATTE
Atteint http://fr.archive.ubuntu.com lucid-updates/multiverse Sources
W: Impossible de récupérer http://apt.cps-cms.org/opt-debian/dists/squeeze/Release Unable to find expected entry main/binary-amd64/Packages in Meta-index file (malformed Release file?)
W: Impossible de récupérer http://apt.cps-cms.org/debian/dists/squeeze/main/binary-amd64/Packages.gz 404 Not Found
W: Impossible de récupérer http://apt.cps-cms.org/debian/dists/squeeze/contrib/binary-amd64/Packages.gz 404 Not Found
E: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.
$ sudo apt-get install opt-zope2.9
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet opt-zope2.9
Je ne comprend pas, y a t-il à votre connaissance des cas similaires ?
Voici les deux lignes concernées de mon sources.list sur la machine
virtuelle en Ubuntu 10.04 sur laquelle j'ai testé :

deb http://apt.cps-cms.org/debian squeeze contrib
deb http://apt.cps-cms.org/opt-debian squeeze contrib

Je viens de refaire un update, et je vois bien le paquet opt-zope2.9
Essayez donc d'enlever « main » des lignes correspondantes dans le
vôtre. J'ai l'impression qu'apt-get est moins tolérant qu'aptitude (que
j'utilise systématiquement) en la matière.

Et sinon, postez donc le contenu exact de vos lignes
--
Georges Racinet, http://www.racinet.fr
Zope/CPS expertise, assistance & development
GPG: 0x4862FFF7 identi.ca & twitter: gracinet
Florent JOUATTE
2011-04-11 09:30:04 UTC
Permalink
Raw Message
Bonjour,

Ca fonctionne maintenant ! Merci !

Les lignes de mon sources.list étaient :

deb http://apt.cps-cms.org/debian squeeze main contrib
deb http://apt.cps-cms.org/opt-debian squeeze main contrib

Sans les main ça marche nickel chrome !

Merci beaucoup.

Cordialement,

Florent Jouatte

Loading...