Discussion:
Problème de passage plateforme Windows --> Unix
(too old to reply)
Jean-Baptiste Joblin
2009-06-02 07:52:59 UTC
Permalink
Raw Message
Bonjour,
Je me permet de vous contacter afin de connaître la marche à suivre pour
déployer CPS sur une plate forme type RED HAT AS3. Le problème c'est que
initialement,
cette GED était en local sous windows. Je souhaite aujourd'hui la déployer
sur serveur Linux type RED HAT AS3, seulement l'import de la GED actuelle ne
fonctionne pas lorsque
l'on exporte celle-ci de Windows vers Linux...quelqu'un aurait-il une
solution à ce problème ?

Je vous remercie par avance de l'aide qui pourrait m'être apportée, ce
blocage me retarde malheureusement.

Cordialement,
Jean-Baptiste
Jean-Baptiste Joblin
2009-06-02 11:38:09 UTC
Permalink
Raw Message
Informations complémentaires :
Lorsque je fais l'import, voici le message : "The objects cps does not
support this operation"

Merci par avance pour votre aide


Bonjour,
Post by Jean-Baptiste Joblin
Je me permet de vous contacter afin de connaître la marche à suivre pour
déployer CPS sur une plate forme type RED HAT AS3. Le problème c'est que
initialement,
cette GED était en local sous windows. Je souhaite aujourd'hui la déployer
sur serveur Linux type RED HAT AS3, seulement l'import de la GED actuelle ne
fonctionne pas lorsque
l'on exporte celle-ci de Windows vers Linux...quelqu'un aurait-il une
solution à ce problème ?
Je vous remercie par avance de l'aide qui pourrait m'être apportée, ce
blocage me retarde malheureusement.
Cordialement,
Jean-Baptiste
Racinet Georges
2009-06-02 12:26:57 UTC
Permalink
Raw Message
Post by Jean-Baptiste Joblin
Lorsque je fais l'import, voici le message : "The objects cps does
not support this operation"
Merci par avance pour votre aide
Tenteriez vous par hasard un import ZMI au format .zexp ? Dans ce cas,
en effet je ne suis pas sûr que cela soit possible.
Ce qu'on fait habituellement, c'est monter une instance Zope avec le
même Products et mettre dedans le Data.fs récupéré de l'autre plate-
forme.

Cela dit, vous devriez sans doute donner plus de détails sur
l'applicatif.

Cordialement,

GR
Post by Jean-Baptiste Joblin
Bonjour,
Je me permet de vous contacter afin de connaître la marche à suivre
pour déployer CPS sur une plate forme type RED HAT AS3. Le problème
c'est que initialement,
cette GED était en local sous windows. Je souhaite aujourd'hui la
déployer sur serveur Linux type RED HAT AS3, seulement l'import de
la GED actuelle ne fonctionne pas lorsque
l'on exporte celle-ci de Windows vers Linux...quelqu'un aurait-il
une solution à ce problème ?
Je vous remercie par avance de l'aide qui pourrait m'être apportée,
ce blocage me retarde malheureusement.
Cordialement,
Jean-Baptiste
_______________________________________________
cps-users-fr
Gestion de l'abonnement : <http://lists.nuxeo.com/mailman/listinfo/cps-users-fr
--
Georges Racinet, http://www.racinet.fr
Zope/CPS/Plone expertise, assistance & development
GPG: 0x4862FFF7
Racinet Georges
2009-06-02 17:09:03 UTC
Permalink
Raw Message
Post by Jean-Baptiste Joblin
Bonjour,
Un grand merci pour cette réponse rapide et au combien efficace. Je
me suis empressé d'essayer cette manipulation, et cela fonctionne
très bien. Vraiment un grand merci.
Voilà qui est bon pour le moral :-)
Post by Jean-Baptiste Joblin
Cela dit, et en aparté, je me retrouve face à un petit problème
lorsque je fait un arrêt de Zope, puis un redémarrage, celui-ci me
met le message d'erreur ci-dessous et pour plus de compléments sous
"Message erreur.JPG".
C'est à dire "CPSOOo cannot be loaded because there are some
dependencies missing :"
C'est sans doute gênant, je suppose que vous n'avez pas CPSOOo par
hasard et que cela doit casser les documents qui l'utilisent.
Je ne connais pas ce produit, mais le README a l'air bien complet.
Vous l'avez dans Products/CPSOOo/README.txt

Dans la version actuelle : http://svn.nuxeo.org/trac/pub/browser/CPS3/products/CPSOOo/trunk/README.txt
Post by Jean-Baptiste Joblin
DeprecationWarning : The zLog package is deprecated and will be
removed in Zope 2.11. Use the Python logging module instead.
Vous pouvez ignorer celles-là les yeux fermés. Les erreurs de
dépréciation indiquent aux développeurs que leur façon de faire est
obsolète mais continue de fonctionner. Une façon de leur mettre la
honte et de les motiver à migrer leur code.

En l'occurrence, c'est simplement que Zope embarquait un mécanisme
pour produire ses traces à une époque où cela n'existait pas dans la
librairie standard python. Quand le module logging a été ajouté à
python, ils l'ont intégré et créé cette alerte. Imaginez les centaines
d'appels à changer... D'ailleurs, pour la petite histoire, je crois
bien avoir vu que zLog a été réintégré dans Zope 2.11, finalement.

D'une manière générale, sauf si vous êtes sur les versions les plus
récentes de CPS, vous allez voir passer malheureusement beaucoup de
lignes d'erreur qui ne sont que de la pollution (à propos du
catalogue, notamment).

D;ailleurs, à titre de curiosité, quelle version de CPS avez vous ?
Post by Jean-Baptiste Joblin
Sauriez-vous d'où peut provenir cette erreur ?
Vous remerciant pour votre implication.
Cordialement,
Jean-Baptiste
Lorsque je fais l'import, voici le message : "The objects cps does
not support this operation"
Merci par avance pour votre aide
Tenteriez vous par hasard un import ZMI au format .zexp ? Dans ce
cas, en effet je ne suis pas sûr que cela soit possible.
Ce qu'on fait habituellement, c'est monter une instance Zope avec le
même Products et mettre dedans le Data.fs récupéré de l'autre plate-
forme.
Cela dit, vous devriez sans doute donner plus de détails sur
l'applicatif.
Cordialement,
GR
Bonjour,
Je me permet de vous contacter afin de connaître la marche à suivre
pour déployer CPS sur une plate forme type RED HAT AS3. Le problème
c'est que initialement,
cette GED était en local sous windows. Je souhaite aujourd'hui la
déployer sur serveur Linux type RED HAT AS3, seulement l'import de
la GED actuelle ne fonctionne pas lorsque
l'on exporte celle-ci de Windows vers Linux...quelqu'un aurait-il
une solution à ce problème ?
Je vous remercie par avance de l'aide qui pourrait m'être apportée,
ce blocage me retarde malheureusement.
Cordialement,
Jean-Baptiste
_______________________________________________
cps-users-fr
Gestion de l'abonnement : <http://lists.nuxeo.com/mailman/listinfo/cps-users-fr
--
Georges Racinet, http://www.racinet.fr
Zope/CPS/Plone expertise, assistance & development
GPG: 0x4862FFF7
_______________________________________________
cps-users-fr
Gestion de l'abonnement : <http://lists.nuxeo.com/mailman/listinfo/cps-users-fr
--
Cordialement,
Jean-Baptiste JOBLIN
Consultant, Capgemini Finance & Services
Ingénieur EFREI
<Message erreur.JPG>
--
Georges Racinet, http://www.racinet.fr
Zope/CPS/Plone expertise, assistance & development
GPG: 0x4862FFF7
Jean-Baptiste Joblin
2009-06-05 12:51:38 UTC
Permalink
Raw Message
Post by Jean-Baptiste Joblin
Bonjour,
Un grand merci pour cette réponse rapide et au combien efficace. Je me
suis empressé d'essayer cette manipulation, et cela fonctionne très bien.
Vraiment un grand merci.
Voilà qui est bon pour le moral :-)
Je confirme, c'est effectivement rassurant et bon pour le moral. Vous y êtes
en tous les cas pour quelque chose ;)
Post by Jean-Baptiste Joblin
Cela dit, et en aparté, je me retrouve face à un petit problème lorsque je
fait un arrêt de Zope, puis un redémarrage, celui-ci me met le message
d'erreur ci-dessous et pour plus de compléments sous "Message erreur.JPG".
C'est à dire "CPSOOo cannot be loaded because there are some dependencies
missing :"
C'est sans doute gênant, je suppose que vous n'avez pas CPSOOo par hasard
et que cela doit casser les documents qui l'utilisent.
Je ne connais pas ce produit, mais le README a l'air bien complet. Vous
l'avez dans Products/CPSOOo/README.txt
http://svn.nuxeo.org/trac/pub/browser/CPS3/products/CPSOOo/trunk/README.txt
The zLog package is deprecated and will be removed in Zope 2.11. Use the
Python logging module instead.
Vous pouvez ignorer celles-là les yeux fermés. Les erreurs de dépréciation
indiquent aux développeurs que leur façon de faire est obsolète mais
continue de fonctionner. Une façon de leur mettre la honte et de les motiver
à migrer leur code.
En l'occurrence, c'est simplement que Zope embarquait un mécanisme pour
produire ses traces à une époque où cela n'existait pas dans la librairie
standard python. Quand le module logging a été ajouté à python, ils l'ont
intégré et créé cette alerte. Imaginez les centaines d'appels à changer...
D'ailleurs, pour la petite histoire, je crois bien avoir vu que zLog a été
réintégré dans Zope 2.11, finalement.
D'une manière générale, sauf si vous êtes sur les versions les plus
récentes de CPS, vous allez voir passer malheureusement beaucoup de lignes
d'erreur qui ne sont que de la pollution (à propos du catalogue, notamment).
D;ailleurs, à titre de curiosité, quelle version de CPS avez vous ?
J'utilise la version 3.2.4 de CPS. Désolé de ne répondre que maintenant, je
reviens d'un court congé.
Pour le message d'erreur recensé, effectivement il ne contrarie en rien le
fonctionnement général de CPS, j'essaierai tout de même de me pencher plus
en détail sur CPSOOo lorsque j'aurais un peu de temps, je vous ferai un
retour dessus après familiarisation.

J'aurais une petite question subsidiaire au sujet de la restauration, est-il
possible de restaurer par exemple un fichier, ou même un sous-espace de
travail, lorsque celui-ci est par erreur supprimé par un membre de l'espace
de travail? (ceci se réalise via ZMI je suppose)
Post by Jean-Baptiste Joblin
Sauriez-vous d'où peut provenir cette erreur ?
Vous remerciant pour votre implication.
Cordialement,
Jean-Baptiste
Lorsque je fais l'import, voici le message : "The objects cps does not
support this operation"
Merci par avance pour votre aide
Tenteriez vous par hasard un import ZMI au format .zexp ? Dans ce cas, en
effet je ne suis pas sûr que cela soit possible.
Ce qu'on fait habituellement, c'est monter une instance Zope avec le même
Products et mettre dedans le Data.fs récupéré de l'autre plate-forme.
Cela dit, vous devriez sans doute donner plus de détails sur l'applicatif.
Cordialement,
GR
Bonjour,
Je me permet de vous contacter afin de connaître la marche à suivre pour
déployer CPS sur une plate forme type RED HAT AS3. Le problème c'est que
initialement,
cette GED était en local sous windows. Je souhaite aujourd'hui la déployer
sur serveur Linux type RED HAT AS3, seulement l'import de la GED actuelle ne
fonctionne pas lorsque
l'on exporte celle-ci de Windows vers Linux...quelqu'un aurait-il une
solution à ce problème ?
Je vous remercie par avance de l'aide qui pourrait m'être apportée, ce
blocage me retarde malheureusement.
Cordialement,
Jean-Baptiste
_______________________________________________
cps-users-fr
Gestion de l'abonnement : <
http://lists.nuxeo.com/mailman/listinfo/cps-users-fr>
--
Georges Racinet, http://www.racinet.fr
Zope/CPS/Plone expertise, assistance & development
GPG: 0x4862FFF7
_______________________________________________
cps-users-fr
Gestion de l'abonnement : <
http://lists.nuxeo.com/mailman/listinfo/cps-users-fr>
--
--
Georges Racinet, http://www.racinet.fr
Zope/CPS/Plone expertise, assistance & development
GPG: 0x4862FFF7
_______________________________________________
cps-users-fr
Gestion de l'abonnement : <
http://lists.nuxeo.com/mailman/listinfo/cps-users-fr>
Loading...