Discussion:
pb d'accents dans le sujet des messages
(too old to reply)
Malika LBAOUCH
2009-04-29 15:41:50 UTC
Permalink
Raw Message
Bonjour,

Mon site cps envoie des message sans accents, pourtant le localizer semble
paramétré en français par défaut.

Notre gestion de messages se fait au travers de la zmi et de
portal_subscriptions.

Est ce que quelqu'un connait la solution?

D'avance merci.

Environment : Zope/(Zope 2.7.4-0, python 2.3.4, linux2) ZServer/1.1 CPS/3.2

Malika LB.
ACOSS
Racinet Georges
2009-04-30 11:45:49 UTC
Permalink
Raw Message
Post by Malika LBAOUCH
Bonjour,
Mon site cps envoie des message sans accents, pourtant le localizer
semble paramétré en français par défaut.
Notre gestion de messages se fait au travers de la zmi et de
portal_subscriptions.
Est ce que quelqu'un connait la solution?
Il s'agit du sujet du mail, n'est-ce pas ? En fait, jusqu'à il y a
très peu, le mécanisme d'envoi de CPSSubscriptions enlevait
explicitement les accents des sujets, car la librairie en aval ne
savait pas les traiter correctement.

Références: http://svn.nuxeo.org/trac/pub/ticket/1991, qui profite du
fait que j'ai remplacé dans le futur 3.5 le module d'envoi utilisé par
CPSSubscriptions par celui, plus récent, de CPSCourrier (http://svn.nuxeo.org/trac/pub/ticket/1762
) et que Marc-Aurèle l'a amélioré pour traiter les caractères accentué
(http://svn.nuxeo.org/trac/pub/ticket/1956)

Donc la solution, c'est vérifier que la version de la librairie SMTP
python qui va avec Zope 2.7.4 est capable de les gérer correctement,
et adapter tout ça au contexte CPS 3.2.
Post by Malika LBAOUCH
D'avance merci.
Environment : Zope/(Zope 2.7.4-0, python 2.3.4, linux2) ZServer/1.1 CPS/3.2
Malika LB.
ACOSS
____________
--
Georges Racinet, http://www.racinet.fr
Zope/CPS/Plone expertise, assistance & development
GPG: 0x4862FFF7

Loading...